Bug #859

Image Element Issues

Added by Jules (wtf) almost 5 years ago. Updated over 3 years ago.

Status:CompletedStart date:11/06/2015
Priority:NormalDue date:
Assignee:Dalton Cabrera% Done:

100%

Category:-
Target version:5.9.44
UBot Version:5.9.19 Browser:Chrome 39
UBot Studio Edition:Dev

Description

Code hangs / freezes when run in studio & compiled bot rarely completely loop more than 50 times.

navigate("http://www.ubotstudio.com/resources","Wait")
wait for browser event("Page Loaded","")
loop(1000) {
save browser image("{$special folder("Desktop")}\\1.png")
wait(1)
save element image(<class="btn btn-primary">,"{$special folder("Desktop")}\\2.png")
wait(1)
}

saveimagetest.ubot (1.04 KB) Jules (wtf), 11/06/2015 05:07 am

jules-test.ubot (1.81 KB) Code Docta, 11/07/2015 09:04 am

Screen Shot 2016-04-15 at 11.11.02 AM.png (211 KB) Jason Kelley, 04/15/2016 02:14 pm

History

#1 Updated by Jules (wtf) almost 5 years ago

This issue is present in Win7 Ultimate and Windows 8

#2 Updated by Phil Spurr almost 5 years ago

I replicated the same issue with an out-of-the-install of 5.9.4, however I'm on windows 8.2

#3 Updated by Code Docta almost 5 years ago

same here in 5.9.4 on win 7 both browsers

When running these scripts in browser 21 all appears to run fine and gets the correct images and is relatively fast.

when running in browser 39 it is noticeably slower and the browser crashes eventually.

The images don't get saved nor does the wait for element work even with time out set. Goes past timeout.

If you right click on the save element image nodes and run they will either save an image or crash browser/ubot. Then I will have to kill ubot in task manager to start over.

Seems it cant find elements in the DOM and errors are not handled.

Also running one node it will take image of whole browser view rather then the element.

After running in 21 please empty image file on desktop to see results if any while running in 39.

At first I thought it may be the same image name in tab one. No issues in 21.

Then I tried "fallow execution" on and off. No difference.

It will get thru first 1-3 loops but usually very slow and eventually crashes.

If you hit stop on first tab after some time then try second tab it will crash.

#4 Updated by Miriam MB almost 5 years ago

  • Status changed from Pending to New

#7 Updated by Jason Kelley over 4 years ago

Run with Error Level set to none, I am on loop #400 and no issue.

http://www.screencast.com/t/5FIaW8Lnk0rf

#8 Updated by Jason Kelley over 4 years ago

  • UBot Version changed from 5.9.4 to 5.9.19

#9 Updated by Dan X over 4 years ago

Looks like it has something todo with UbotCefSharpBrowser.exe

After going through some loops, the browser looks a bit strange as well. Like if it was resized incorrectly.
It looks a bit "streched" You can't click anything on the page anymore. And you even can't reload the page.

http://screencast.com/t/gfwh3XePcc

#10 Updated by Dan X over 4 years ago

If I run the script without wait commands Ubot Studio will crash at some point:

set(#counter,0,"Global")
ui stat monitor("Counter",#counter)
reset browser
navigate("http://www.ubotstudio.com/resources","Wait")
wait for browser event("Page Loaded","")
loop(1000) {
increment(#counter)
save browser image("{$special folder("Desktop")}\\1.png")
save element image(<class="btn btn-primary">,"{$special folder("Desktop")}\\2.png")
}

#11 Updated by Code Docta over 4 years ago

saveimagetest.ubot

is still freezing in 5.9.19 browser 39

without any changes for me

the main browser gets distorted which this is where the "browser image" comes from.

#12 Updated by Code Docta over 4 years ago

I just want to be clear. I was testing jules-test.ubot and my screen was half covered while catching up on Skype.

SO I did not see the browser freeze and thought it was running fine since I saw that it was looping with out stopping.

SO, I stated in the chat that this file was working fine.

I tested again and I saw that the browser is freezing just like the one above this and what others are getting.

Both files fail in the main browser!

Thanks Nick

#13 Updated by Jules (wtf) about 4 years ago

Error level makes no difference, still needs fixing.

#14 Updated by Code Docta about 4 years ago

Tested in browser 49

still the same issues...

#15 Updated by Seth Turin about 4 years ago

I can confirm that the problem is fixed if you turn off logging. I'll see if I can wire a more permanent solution as well.

#16 Updated by Jules (wtf) about 4 years ago

Are you saying this is newly fixed in 49 or its fine in 39 with logging turned off?

I have tested in 39 with logging turned off and it still freezes.

#17 Updated by Miriam MB about 4 years ago

The issue is still scheduled to be resolved. This ticket will be updated once the issue is resolved.

#18 Updated by Jules (wtf) about 4 years ago

Please be more precise:

Quote Seth "I can confirm that the problem is fixed if you turn off logging."

is this right or not?

#19 Updated by Jules (wtf) about 4 years ago

And if so, in what version?

#20 Updated by Miriam MB about 4 years ago

The issue is fixed when the ticket is set to resolved.

A previous suggestion did not work to alleviate the issue.

It will have been fixed when the tracker is set to "Resolved."

Please be patient while we work on this issue. We will let you know if this tracker needs any more information on the issue.

#21 Updated by Jules (wtf) about 4 years ago

As long as you know Seth's suggestion didnt fix it, thats all I was trying to ascertain. Thank you.

#22 Updated by Macster [UBotter Labs] about 4 years ago

Today's latest version 5.9.27 with new browser "Chrome 49" and this year old bug is still not fixed !? :(

#23 Updated by Seth Turin about 4 years ago

  • Assignee set to Dalton Cabrera

#24 Updated by Dalton Cabrera about 4 years ago

  • Status changed from New to In Progress

#26 Updated by Dalton Cabrera over 3 years ago

  • Status changed from In Progress to Resolved

#27 Updated by Miriam MB over 3 years ago

  • % Done changed from 0 to 100

#28 Updated by Miriam MB over 3 years ago

  • Target version set to 5.9.44

#29 Updated by Miriam MB over 3 years ago

  • Status changed from Resolved to Completed

Also available in: Atom PDF